UA-38832503-1 Jump to content
  • Announcements

    • Rebecah

      Private Messages   11/10/2017

      I have finally restored most of the private messages in a separate database.   Click Here and log in.  You should be able to find your messages.  That is all I have there for now.  Most images and files should be available..now.   You must open this message to use the link.
    • Rebecah

      We are still here! :)   11/13/2017

      It looks like all our hard work paid off, as we were not shut down yesterday.  Thank so much for all your help!

Recommended Posts

All of a sudden all my Custom rugs has  a "shadow" (the size of the original carpet) around it. Can anybody tell me what may be the cause and how can I fix it, please?

Rug.JPG

Share this post


Link to post
Share on other sites

Beck, the problem is all my custom rugs do this, not just my own. Most of them are cloned from Echo's rugs and some like the one in the picture from Phelana's rug.

I attached this rug's file and the mesh. Thank you, Beck!  

Rugs.rar

Share this post


Link to post
Share on other sites

Did you update your computer or your operating system?  I had this issue with everything having dark shadows, but I can't remember what I had to do.

Share this post


Link to post
Share on other sites

Maybe it has something to do with Win 10's latest update? I turned shadows off in the game but it didn't help. I don't think it's really a shadow problem :( Or maybe it is :blush:

Share this post


Link to post
Share on other sites

Add a mod that affects shadows or have hugelunatic's rug fix mod? Your update/drivers might be affecting it?

Share this post


Link to post
Share on other sites

I think I had to reduce my shadows.  I'm sorry I just can't remember, but it has something to do with the updated drivers, like Gina says.

Share this post


Link to post
Share on other sites

I just want to let you know, the problem resolves itself LOL After the latest Win 10 update those shadows are gone! :ExcitedSmiley:

Share this post


Link to post
Share on other sites

I finally looked at this rug and it is the rug mesh itself that is not done properly.  They used a blend in the material, so your round rug wasn't covering his full mesh.  blend is not the proper setting to use.  It's not your video card nor drivers.  Just so you don't have to worry about that.  Once you told me you turn shadows off, I know something was wrong, but I just had not had a chance to look at the file.  Sorry it took me so long.

 

Share this post


Link to post
Share on other sites

Thank you very much, Beck, for looking at the files for me! I know you need rest, so I doubly appreciate it. picgifs-thank-you-7412931.gif

So the problem lies with the mesh; which means I won't use that mesh again :)

Share this post


Link to post
Share on other sites

Not his actual mesh, it's his material settings.  I will try to show you the difference as soon as I can get some rest okay?

Share this post


Link to post
Share on other sites

Okay, I finally got some sleep.  I feel a lot better.  My computer is all fixed up.  Long story.  

Now if you look at the Material Definition TMXT for echo's rug and then look at phel's TMXT you will see he/she used the blend option where that would not work for this type of item.  People used to suggest using the blend option to allow for hiding area's of a mesh, but that really does not work properly.  I don't know all of these settings in the TMXT area, but echo's is used properly.

phel.jpgEcho.jpg

I have fixed the phel rug mesh and I think if you try it with your recolor Alet you should find it works properly now.  I did not go in game and check this so if you could and get back to me.  I'd appreciate it.

 

Rugs.zip

Share this post


Link to post
Share on other sites

Thank you, Beck!

I began to suspect my drivers again, because the shadows are still there :(

The Bambi rug was cloned from Echo's mesh and the round rug is a recolour of Phelana's rug.

StillShadows.JPG

I also found the rugs disappear when I zoomed out in game; only the shadows stay :hmm:

ZoomOut.JPG

 

Share this post


Link to post
Share on other sites

It's not your drivers Alet, at least I'm fairly sure.  I have a feeling you have other copies of echo and phel mesh files in your folders somewhere.  Try these in a clean game...please.

The disappearing is what that blend options does.

 

Share this post


Link to post
Share on other sites

Be sure to check for windkeepers rugs too as she/he used echo's rug and really messed it up.

Share this post


Link to post
Share on other sites

Beck, I've been spending the whole day between the grand kids and the game LOL

First I took out all Echo's and Phelana's rugs - meshes and recolours. I made sure I took out them all! Then I took out everything from Windkeeper I had in game. Then I took out ALL the custom rugs. And still got the shadow Aaaargh!being-confused-smiley-emoticon.gif

Then I took out the whole downloads folder and only put in Phelana's mesh and my rug - the ones you sent back to me. STILL shadow! 12483c4879bc711d82982a12c39caf48.png

Then I regenerate a totally new game with again only Phelana's mesh and my rug; The result  Shadow!

 

Thanks to Gina I got some light in the tunnel - a cheat: boolProp objectShadows false bursting-head-smiley-emoticon.gif

Share this post


Link to post
Share on other sites

It's a bandaid as it doesn't actually solve it but it masks it so it doesn't drive you nuts anyway!

Share this post


Link to post
Share on other sites

The thing is these rugs do not have a shadow mesh in them.  I'm sorry Alet I just don't know what else it could be.  Maybe echo's material definition has something wrong with it too.  

Share this post


Link to post
Share on other sites

I noticed that too. That there is no special texture for the shadows like there is normally and yet obviously there IS one which means they have been incorporated inside the mesh itself right? You can regroup and "hide" groups in milkshape but they still retain their properties. I think something like that might have happened maybe? 

Share this post


Link to post
Share on other sites

No Gina, what she is seeing is the portions of the rug mesh that are not covered.  There isn't any shadow at all in them.  You actually can't do that, the way you're are saying.  The shadow mesh has different setting etc.  Sometimes people import the shadow mesh and don't fix the settings to what a shadow needs to be set at.  I do find that quite often.  I hope that I explain it well enough to help you understand it.  Sorry still not doing great today, can't seem to stay awake today.  

Share this post


Link to post
Share on other sites

Ok I THINK I get what you are meaning. Or at least sort of. Hope you can get your rest in!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×